FortiGate High Availability (Active / Passive)

KB ID 0001730

So my aim was to setup FortiGate High Availability failover in Active / Passive mode. I’m setting this up in EVE-NG and here’s what my lab looks like;

Note: Im using TWO connections for Heartbeat/Failover, you can simply use one if you prefer.

FortiGate High Availability (Pre-Requisites)

Obviously the firewalls need to be the same! For physical firewalls that’s straightforward, but be careful if you are using virtual FortiGates, make sure they are the same hardware and licence versions!

As you can see in my topology (above), each port needs to be connected to the same network on BOTH firewalls.

Make sure both firewalls are running the SAME firmware.

Make sure the interfaces are not getting their IP addresses from DHCP, or PPPoE.

I’m assuming the primary firewall is all setup and configured properly, the secondary firewall then needs to be built, licensed, and internet connected (so it can update etc). Note: It will take it’s config from the primary firewall when configured.

FortiGate High Availability (Active Passive) From Command Line

I know, Fortinet like to say that there’s no need to be working at command line these days, but when you see how easy it is to setup from CLI, you might choose to do it that way instead.

Primary FortiGate High Availability Setup

FortiGate uses priority to set the primary firewall, by default it sets the value to 128. So I’m going to set my Primary firewall to 200 and my Secondary firewall to 100.

Here are the commands you can simply copy and paste;

[box]

config system ha
set group-id 10
set group-name HA-GROUP
set mode a-p
set password Password123
set hbdev port3 0 port4 0
set session-pickup enable
set override enable
set override-wait-time 10
set priority 200
end

[/box]

What does all that mean? The Group ID and Group Name, are shared by all firewalls in the cluster. (Yes cluster, you can scale this up to more firewalls). Mode simply sets the mode to a-p (active passive). Hbdev denotes the interfaces used for the heartbeat network, (the zeros denote that they will be used equally). Session-pickup allows the firewalls to share the session state table for your clients, (i.e. provides seamless TCP session failover). Override is enabled, this will fail back the the primary firewall when it becomes available.  Note: wait-time is enabled and set to 10 seconds to avoid any ‘flap / stutter’ that may cause disconnections when executing the override. Then finally the priority is set to 200.

Secondary FortiGate Hight Availability Setup

Practically the same, but you don’t need to set override, and the priority will be lower (100).

[box]

config system ha
set group-id 10
set group-name HA-GROUP
set mode a-p
set password Password123
set hbdev port3 0 port4 0
set session-pickup enable
set priority 100
end

[/box]

FortiGate HA Monitor and TroubleShooting

At this point go and have a coffee, the config needs replicating from the primary to the secondary, and this can take a few minutes. Use the following command to check;

[box]

get system ha status

[/box]

You want to see them both ‘in-sync‘.

To troubleshoot, use;

[box]

diagnose system ha status

[/box]

FortiGate Failover (Active Passive) From GUI

On the Primary (pre configured) firewall, System > HA  > Change the drop down to Active-Passive.

  • Device Priority: 200
  • Group name: HA-GROUP {or something sensible}.
  • Password: {needs to match on both firewalls}.
  • Sesión pickup: Enabled {replicates client session data}.
  • Monitor Interfaces: {you can leave this blank, unless you only want to monitor certain interfaces}.
  • Heartbeat Interfaces: {enter one or more interfaces}.

What’s Management interface Reservation? : You can use this to have separate management for each firewall, (usually you can’t get to the standby/secondary firewall for GUI/SSH management etc).

Clock OK when complete

You should see something like this;

Jump onto the Secondary firewall, and set it the same, (with the exception of the priority).

Note: Override (Fail Back) cannot currently be set in the GUI.

Wait a while and hit refresh, you should see both firewalls in Sync

Possible Bug in 6.4.4 build 1803 (GA)

When carrying out the above procedure (from the web management console), my firewalls did not sync, while trouble shooting at command line they were both set as primary and appeared not to be able to see the other, they were saying;

{Firewall Serial Number}is selected as the master because it’s the only member in the cluster.

Despite many hours of troubleshooting/rebuilding, this kept happening, it worked fine when configured from command line, but not from the GUI. When I checked the commands after using the GUI I noticed that “set group-id {number}” was missing from the config. If I added this manually it started syncing straight away? 

Related Articles, References, Credits, or External Links

Thanks to the good folk at Fortinet for sending me some licences to test this (much appreciated).

Configuring Cisco HSRP

KB ID 0000946 

Problem

Cisco HSRP: Normally your client machines have one route off the network, (their default gateway). But what if that goes down? HSRP aims to solve this problem by assigning a ‘Virtual IP address’ to your default gateway (or default route). So that IP can be shared amongst two or more possible devices (routers, or layer 3 switches).

Above, we have a client 192.168.1.10 that has two possible routes off the network, (.254 and .253). We will setup a virtual IP of .250 and both routers can use that IP, (if they are the active gateway). Below is a brief overview of how to set it up.

Deploy Cisco HSRP

Setting up Cisco HSRP

1. On the first router (Router0), add the standby IP address (192.168.1.250) the ‘1’ denotes the standby group (a number from 0 to 4096). It comes up as standby, then after it has checked (via multicast address 224.0.0.2 on UDP port 1985). It finds no other live HSRP devices using that IP address so it becomes ‘Active’.

[box]

Router0>enable
Router0#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router0(config)#interface GigabitEthernet0/0
Router0(config-if)#standby 1 ip 192.168.1.250
Router0(config-if)#

%HSRP-6-STATECHANGE: GigabitEthernet0/0 Grp 1 state Speak -> Standby

%HSRP-6-STATECHANGE: GigabitEthernet0/0 Grp 1 state Standby -> Active

Router0(config-if)#

[/box]

2. Repeat this on the second Router, this one discovers the ‘Active’ router and sets itself up as ‘Standby’.

[box]

Router1>
Router1>enable
Router1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#interface GigabitEthernet0/0
Router1(config-if)#standby 1 ip 192.168.1.250
Router1(config-if)#
%HSRP-6-STATECHANGE: GigabitEthernet0/0 Grp 1 state Speak -> Standby

Router1(config-if)#

[/box]

3. You can prove this by running show standby (or do show standby in configure terminal mode).

[box]

Router0

Router0#show standby
GigabitEthernet0/0 - Group 1 (version 2)
State is Active
8 state changes, last state change 00:02:02
Virtual IP address is 192.168.1.250
Active virtual MAC address is 0000.0C9F.F001
Local virtual MAC address is 0000.0C9F.F001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.055 secs
Preemption disabled
Active router is local
Standby router is 192.168.1.253
Priority 100 (default 100)
Group name is hsrp-Gig0/0-1 (default)
Router0#

Router1

Router1#show standby
GigabitEthernet0/0 - Group 1 (version 2)
State is Standby
3 state changes, last state change 00:10:44
Virtual IP address is 192.168.1.250
Active virtual MAC address is unknown
Local virtual MAC address is 0000.0C9F.F001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.125 secs
Preemption disabled
Active router is 192.168.1.254
Standby router is local
Priority 100 (default 100)
Group name is hsrp-Gig0/0-1 (default)
Router1#

[/box]

4. That is HSRP configured! However there are a few changes you might want to make, for example, what if one router had a 100MB leased line, and the other was a 2MB ADSL line, you would want the fastest one to be in use, (as long as it was up). To achieve that, give the router with the fastest connection a higher priority (you may notice above, that by default the priority is 100). Be aware, even if a router has the highest priority, it wont ‘seize’ the virtual IP, it just sits and waits until it’s available. For our 100MB and 2MB example that’s not good. We would want Router1 to seize the virtual IP as soon as it can. To do that we need to set it to preempt. (Note: This process is called ‘launching a coup’).

[box]

Router1(config)#interface GigabitEthernet0/0
Router1(config-if)#standby 1 priority 105
Router1(config-if)#standby 1 preempt

[/box]

5. At this point it’s important to say, that in our scenario we would also need to setup a virtual IP for the ‘other side’ of the routers (i.e their GigabitEthernet 0/1 interfaces), or the remote client (172.16.1.10) would not be able to return our ‘pings’ or get any traffic back to us. So lets setup a virtual HSRP address on that side as well. Notice I just use another standby group number.

Note: To work the remote host 172.16.1.10 will need its default gateway changing to the HSRP Virtual IP of 172.16.1.250.

[box]

Router0 

Router0(config)#interface GigabitEthernet0/1
Router0(config-if)#standby 2 ip 172.16.1.250
Router0(config-if)#

Router1

Router1(config)#interface GigabitEthernet0/1
Router1(config-if)#standby 2 ip 172.16.1.250
Router1(config-if)#

[/box]

6. Finally we have set Router0 with the highest priority and set it to seize the virtual IP as soon as it can. But what if another interface on Router1 goes down? e.g. If the GigabitEthernet 0/1 interface were to go down, HSRP would not do anything because it’s tracking both the GigabitEthernet 0/0 interfaces, so communications would fail.

To solve the problem we need to tell it which interfaces to ‘Track’. In our example we need to track GigabitEthernet 0/1, if that goes down we need to give the virtual IP address to the standby ‘router’. This works because once we tell it to ‘track’ the GigabitEthernet 0/1 interface, if that were to fail it will DECREMEMT the routers priority by 10. So for Router0 its priority would drop to 95, this is five less than the default value of 100 (on Router1). But Remember, at the moment that fail-over would still fail, unless you allow Router1 to preempt and launch a coup.

[box]

Router0 

Router0(config)#interface GigabitEthernet0/0
Router0(config-if)#standby 1 track GigabitEthernet0/1
Router0(config-if)#

Router1

Router1(config)#interface GigabitEthernet0/0
Router1(config-if)#standby 1 preempt
Router1(config-if)#

[/box]

7. We can see that by running a ‘show standby’ on Router0.

[box]

Router0#show standby
GigabitEthernet0/0 - Group 1 (version 2)
State is Active
7 state changes, last state change 00:00:31
Virtual IP address is 192.168.1.250
Active virtual MAC address is 0000.0C9F.F001
Local virtual MAC address is 0000.0C9F.F001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.81 secs
Preemption enabled
Active router is local
Standby router is 192.168.1.253, priority 115 (expires in 7 sec)
Priority 115 (configured 115)
Track interface GigabitEthernet0/1 state Up decrement 10
Group name is hsrp-Gig0/0-1 (default)
GigabitEthernet0/1 - Group 2 (version 2)
State is Active
6 state changes, last state change 00:00:28
Virtual IP address is 172.16.1.250
Active virtual MAC address is 0000.0C9F.F002
Local virtual MAC address is 0000.0C9F.F002 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.81 secs
Preemption disabled
Active router is local
Standby router is 172.16.1.253
Priority 100 (default 100)
Group name is hsrp-Gig0/1-2 (default)
Router0#

[/box]

Related Articles, References, Credits, or External Links

NA

Cisco IOS: Ether-Channel Trunks

KB ID 0001533

Problem

This is a subject that every time I need to create an Ether-Channel I end up checking beforehand, so it’s about time I wrote it up. We are combining two different things, an Ether-channel, (an aggregation of links) and a Trunk (the ability to carry many VLANS). If you are NOT from a Cisco background then you might want to read though the following post first to avoid confusion about the world ‘Trunk‘.

HP and Cisco – VLANs and Trunks Confusion!

So this is what I’m going to create;

I will combine the TWO links between the switches to act at one link (Ether-Channel). An Ether-Channel can have up to eight links.

Note: I’m only concentrating on the Ether-Channel setup so VLANs/VTP and Routing are not covered.

Solution

You can use two types of Ether-Channels PAgP (Port Aggregation Protocol), but WHY when it only works on Cisco switches. LACP (Link Aggregation control Protocol) which is supported by just about everything else, so let’s stick with that! By default a ‘Trunk’ will pass ALL VLANS, you might not want that, I’ll cover filtering VLANs a bit further down.

WARNING: If you simply connect two switches with two cables you will create a LOOP, if you have STP enabled the network will recover and block one of the links, but your colleagues will shake their heads and pull a ‘frowny face’. For that reason ‘SHUT THE PORTS DOWN BEFORE YOU CABLE / CONFIGURE THEM“. 

Starting on Switch1 make sure there’s is no existing Ether-Channels configured;

[box]

SW-1#show etherchannel
                Channel-group listing:
                ----------------------

Group: 1
----------
Group state = L2
Ports: 2   Maxports = 4
Port-channels: 1 Max Port-channels = 4
Protocol:   LACP
Minimum Links: 0

[/box]

Above there is already an Ether-Channel (port-channel) on the switch (group 1) so you would have to use group 2. For arguments sake we will say I don’t have one, so I can use group 1.

Note: ‘show etherchannel summary’ is also a handy command to remember!

[box]

First shut down the uplinks, Note the syntax for the 'range interfaces', may differ from device to device, 
so use the TAB key.

SW-1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW-1(config)#interface range ethernet 0/1 - 2
SW-1(config-if-range)#shutdown

Add the ports to channel group 1, Note 'Active' denotes use LACP, (Passive also works, but one (or both) ends
should be active.)

SW-1(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1

Create a 'trunk' with 802.1q encapsulation.

SW-1(config-if-range)#switchport trunk encapsulation dot1q
SW-1(config-if-range)#switchport mode trunk

[/box]

Then configure the other end the same, (assuming the port numbers are the same!) As mentioned above you can use LACP mode ‘passive‘ but I tend to set both ends active.

Once you have both ends configured and the cables in place, enable the interfaces with a ‘no shutdown‘ command, on both ends!

[box]

SW-1(config)#interface range ethernet 0/1 - 2
SW-1(config-if-range)#no shutdown

[/box]

Filtering VLANs on an Ether-Channel Trunk

Any further port-channel changes need to be done on the port-channel interface, so if you want to filter what’s allowed you simply use the following syntax;

[box]

SW-1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
SW-1(config)#interface Port-channel1
SW-1(config-if)#switchport trunk allowed vlan 1,10,100,200

[/box]

Note: When adding any future VLANS check the syntax, if you simply add a new one it will overwrite all the others, and things will break!

Do all Ether-Channels need to be Trunks? No! Not at all, they can be access ports (as long as they are all in the same VLAN), and they can also be routed uplinks, with an IP address at both ends, (specified in the port-channel interface). 

Related Articles, References, Credits, or External Links

NA

WDS Deploying Windows  Part 3: Carry Out an Unattended Deployment

KB ID 0000738

Problem

In part two we built our reference machine and took an image of it using WDS. Now to automate the deployments we need to create some unattended answer files, these will answer all the questions that the Windows 8 machines will ask while they are building. We will take those files and import them into the WDS server we configured in part one. Finally to make sure everything is working we will deploy Windows 8.

Solution

Download and Install the Windows Assessment and Deployment Kit for Windows 8

1. We used to have the WAIK for Windows 7, now this has been replaced with the ADK. (download link).

2. It’s a MASSIVE download, it will take a long time.

Create a WDS Distribution Share

1. On a drive that has some room (Approx 5GB should be fine,) create a folder.

2. Launch the System Image Manager.

3. In the top left section > Right click ‘Select a Distribution Share’ > Select ‘Create Distribution Share..’

4. Navigate to the folder you created earlier.

5. Now you don’t need to do this next part, but I copy the full contents of the Windows 8 DVD into this folder as well.

6. Like so.

7. Then in the bottom left section > Right click > ‘Select Windows Image..’.

8. Navigate to the Windows 8 Media > Sources Directory > Select ‘install.wim’.

Note: The install.wim MUST match the version you are going to deploy, it’s no good pointing to a Windows 8 Pro image if you are going to deploy Windows 8 Enterprise.

9. Select the version you are going to deploy > OK.

10. This is normal, select yes to create a catalog file. It will take a while, it has to mount the image, interrogate it and create all the components. Now would be a good time to put the kettle on.

Create the Unattended file for WDS (WDSUnattended.xml)

This unattended file will be just for the WDS settings, it will not be applied to the image you are going to deploy. It sets the keyboard and language settings for WDS to use, then it gives the credentials to connect to WDS, and wipes all the partitions from the target machines hard drive. It then repartitions it ready for deployment.

WARNING: As reiterated below, the disk configuration settings below will wipe the target machines drive of ALL partitions, even manufacturers rescue partitions. If you are imaging machines anyway this should not be a problem, but don’t email me to complain of you lose the recovery files for a laptop/PC while you were practicing!

1. Create a new answer file.

2. The components may not start amd64 (if you are deploying x86 images) and some of the numbers might be different on yours. But the main titles of the components will be the same. Locate Microsoft-Windows-Internationa-Core-WinPE.

3. Add it to Pass 1. If you are unfamiliar with SIM, you add a component (or a sub component) to one of the ‘Passes’ in the center, then you can select that component (or sub component) and set the values for its settings in the top right hand section. The SIM builds an XML file in the background which will become the unattended answer file.

4. You will now see this component under pass 1, select it and set the following settings. (These are for my local English Great Britain settings, you may need to change your settings according to your locale).

InputLocale = en-GB SystemLocale = en-GB UILanguage = en-GB UILanguageFallback = en-GB UserLocale = en-GB

5. Select the SetupUILanguage sub component.

UILanguage = en-GB

Wiping the Targets Hard Drive and Partitions with WDS

6. Locate the Microsoft-Windows-Setup component > Disk Configuration sub component.

7. Add to Pass 1.

8. Right click > Insert New Disk.

9. Expand > Disk > Create Partitions > Right click > ‘Insert New CreatePartition’.

10. Select the DISK.

Disk ID = 0 WillWipeDisk = true

11. Select the Partition.

Extend = true Order = 1 Type = Primary

12. Right click ModifyPartition > Insert New ModifyPartition.

13. With the new ModifyPartition selected.

Action = AddlistItem Active = true Extend = false Format = NTFS Label = SYSTEM Letter = C Order = 1 PartitionID = 1

Select Partition to install Image to

1. Locate the WindowsDeploymentService sub component, (also in Microsoft-Windows-Setup).

2. Add to Pass 1.

3. Expand Image Selection > Install To.

Disk ID = 0 PartitionID = 1

4. Expand Login > Credentials.

Domain = {Your domain name i.e. petenetlive.com would be PETENETLIVE). Password = {Of a user with administrative rights – IT WILL GET OBFUSCATED*). Username = {Of a user with administrative rights).

*I used to say ‘encrypted‘, but thats NOT the case, they are simply Base64 encoded.

Attach the Answerfile to the WDS Server

1. Save the file you have just created.

2. Place it in your Remoteinstall folder in the WdsClientUnattend sub folder.

3. Launch the Windows Deployment Services management console > Expand Servers > Right click your server > Properties.

4. Client tab > Tick to enable unattended installation > I’m deploying x64 bit images so next to that option > Browse.

5. Navigate to and select the file you have just created > Open > Apply > OK.

Create the Unattended file for Your Image (OOBEUnattend.xml)

1. Create a new answer file.

2. Locate the Microsoft-Windows-Shell-Setup component.

3. Add to Pass 4.

4. With the component selected.

ComputerName = * CopyProfile = true (Unless you don’t want to copy the profiles from your source image). ProductKey = Your 25 character Windows 8 unlock code Note: Only put in a code of you are deploying with MAK keys or Retail Keys, if you are planning on using KMS leave this option blank RegisteredOrganization = Your business name. RegisteredOwner = Your owners name. ShowWindowsLive = false {now depreciated for Windows 8} TimeZone = GMT Standard Time Note: For other time zones see here

Automatically Join the Domain

1. Locate the Microsoft-Windows-UnattendedJoin component

2. Add to Pass 4.

3. With Identification selected.

JoinDomain = {Your domain name i.e. petenetlive.com would be PETENETLIVE). UnsecureJoin = true

Set the Image Language and Keyboard Settings

4. Locate the Microsoft-Windows-International-Core component.

5. Add to Pass 7.

6. With the component selected.

InputLocale = en-GB SystemLocale = en-GB UILanguage = en-GB UILanguageFallback = en-GB UserLocale = en-GB

7. Locate the Microsoft-Windows-Shell-Setup component > OOBE sub component

8. Add to Pass 7.

9. With the OOBE sub component selected.

HideEULAPage = true HideLocalAccountScreen = true HideOnlineAccountScreen =true HideWirelessSetupInOOBE = true NetworkLocation = Work {sets the firewall settings} ProtectYourPC = 1

Set the Local Administrator Password and Add a Local Administrator

Note: The local admin account is disabled by default, so here I’m setting the local admin’s password, and then creating a new local admin user called Sysadmin.

1. Locate the Microsoft-Windows-Shell-Setup component > UserAccounts sub component

2. Add to Pass 7.

3. With AdmnistratorPassword selected set the password value.

4. Right click LocalAccounts > Insert New LoacalAccount.

5. With LocalAccount selected.

Action = AddListItem Description = Sysadmin DisplayName = Sysadmin Group = Administrators Name = Sysadmin

6. Then set the password value.

7. Save the answer file.

8. Save the file as OOBEUnattand.xml

Attach the Answer file to the Windows 8 Image

1. Launch the Windows Deployment Services Management console.

2. Locate the Windows 8 Image you are attaching the answer file to > Right click > Properties.

3. Tick the option ‘Allow image to install in unattended mode’ > Select File > Browse.

4. Select the OOBEUnattend.xml file you created earlier.

5. Note: It makes a copy of the file and stores it elsewhere calling it ImageUnattend.xml (watch out for this if you need to edit the answer file and nothing changes!)

Deploy Your Windows 8 Image.

1. Boot your target machine to the network via pXe > Press F12 to boot from the WDS.

2. Install an Image.

3. Select the image you want to deploy.

4. After the install, the machine should reboot and present you with a domain logon.

5. And your programs and settings will be pre-configured.

Related Articles, References, Credits, or External Links

2012 – WDS Deploying Windows 8 Part 2: Prepare Windows 8, and Capture to WDS

Formatting Partitions using “FORMAT” (FAT32)

KB ID 0000083

Problem

Before starting the hard drive must be formatted, refer to the PARTITIONING section for more details. You CAN format a partition that is ALLREADY formatted to “wipe it clean”.

WARNING: Formatting a Partition that contains information will DESTROY that information.

This section deals with FAT32 formatting, this is required for operating systems like Windows 95/98/ME but can also be used by Windows 2000 and XP – The only time I would recommend using FAT32 for 2K and XP, is if you are dual booting your PC with two operating systems, and still want to see ALL the drive from either operating system.

Solution

Formatting a Partition

1. First ensure you have a windows 98SE Bootdisk, you can download one, CLICK HERE

2. Boot the PC with your boot disk, ENSURE the boot order is set in the BIOS to boot from the floppy disk BEFORE the hard drive.

3. When The PC has booted simply type format c: {enter}.

4. You will get a warning that you are about to “Wipe” your drive and erase all the data. Press Y then {enter}.

5. The drive will now start formatting, depending on the drive size, this may take a while – time for a coffee :0)

6. The system will now create the File Allocation Table – This is like a “routemap” for your operating system so it can find all its files.

7. You will now be asked to enter a Volume Label, if you have a lot of partitions to do this is a good idea, i.e. Music, WorkStuff etc.

8. If you don’t want a Volume Label, just press {enter} I’m calling this one PETESDRIVE.

9. This will tell you some information about the drive, for example how big it is, this one is approx 4Gb. And that’s it finished.

Related Articles, References, Credits, or External Links

NA

Removing Multiple Partitions from your Hard Drive Using FDISK

KB ID 0000082

Problem

This section assumes you have multiple partitions, and goes through the steps needed to remove them using FDISK

WARNING: Removing partitions DESTROYS all the data in those partitions, make sure you have a backup of your important information.

For this example the hard drive in question has a PRIMARY partition (approx 2Gb) and two LOGICAL DRIVES (each approx 1Gb) if I’ve just confused the hell out of you CLICK HERE

Solution

Deleting Partitions

1. First ensure you have a windows 98SE Bootdisk, you can download one, CLICK HERE

2. Boot the PC with your boot disk, ENSURE the boot order is set in the BIOS to boot from the floppy disk BEFORE the hard drive.

3.To launch FDISK simply type fdisk {enter} at the command prompt, when the program launches press the Y key and {enter} to enable large drive support.

4. This is the main FDISK menu, as we are Deleting partitions we need to change the selection from the default [1] to [3] “Delete partition or logical DOS Drive” Press 3 then {enter}

5. Now remember the LOGICAL drives must be deleted FIRST so we need to select “Delete logical DOS Drive(s) in the Extended partition” Press 3 then {enter}

6. Now the system will display the logical drives, work your way BACKWARDS, the last drive letter here is E so simply push E then {enter}.

7. FDISK will ask you for the volume label – ours does not have one so we can simply press {enter} if yours does it will be listed above in the volume label column.

8. At this point you must confirm by pressing Y then {enter}

9. The default view will change to show you that E: drive has been deleted, and you can continue to delete the D: drive, simply press D then {enter}.

10. Again it will prompt for volume label (See step 8 above).

11. You will be asked to confirm press Y then {enter}.

12. You will now see the Logical drives are BOTH deleted, press Esc to exit.

13. At the confirmation page just press Esc.

14. Back at the main menu! Now the LOGICAL drives are gone you can delete the EXTENDED partition. Press 3 then {enter}.

15. To remove the EXTENDED partition press 2 then {enter}.

16. There is only one EXTENDED partition so press Y then {enter}.

17. More confirmation! Just Press Esc.

18. Now the EXTENDED Partition is gone you can remove the PRIMARY partition press 3 then {enter}.

19. Well we know we want the PRIMARY gone so press 1 then {enter}.

20. Its the only one there :0) Press 1 then {enter}.

21. If you have a volume label enter it, if not press {enter}.

22. Press Y then {enter}.

23. Confirmation screen, just press Esc.

24. Nearly done! Press Esc.

25. Press Esc to exit FDISK, when you are back at command line press Ctrl+Alt+Del to reboot the PC. All your partitions are now removed.

Now you’re done you can either repartition the drive OR if you’re installing Windows 2000 or XP let it do it for you as part of the install process.

To set up simple partitioning (One Partition, one Drive Letter) CLICK HERE

To set up complex partitioning (multiple partitions, multiple drive letters) CLICK HERE

Related Articles, References, Credits, or External Links

NA

Creating Multiple Partitions from your Hard Drive Using FDISK

KB ID 0000081 

Problem

This section assumes you want multiple partitions, and goes through the steps needed to create them using FDISK.

For this example the hard drive in question will have a PRIMARY partition (approx 2Gb) and two LOGICAL DRIVES (each approx 1Gb) if I’ve just confused the hell out of you CLICK HERE

Solution

Creating Partitions

1. First ensure you have a windows 98SE Bootdisk, you can download one, CLICK HERE

2. Boot the PC with your boot disk, ENSURE the boot order is set in the BIOS to boot from the floppy disk BEFORE the hard drive.

3.To launch FDISK simply type fdisk {enter} at the command prompt, when the program launches press the Y key and {enter} to enable large drive support.

4. This is the main FDISK menu, as we are creating partitions we need to create a DOS partition press 1 then {enter}.

5. Now remember that PRIMARY partitions MUST be created first so press 1 then {enter}.

6. FDISK does a drive check, just wait.

7. At this point we DON’T want the default setting or the PRIMARY partition would take up the whole drive, press N then {enter}.

8. FDISK does another drive check, just wait.

9. You need to type in the size (In Megabytes) that you want the PRIMARY partition to be, this is a 4 Gb drive so I’ve typed 2048 Mb (2Gb) then press {enter}.

10. This just confirms the partition was created, press Esc.

11. Now we are back at the main menu, we need to start creating an EXTENDED partition, so press 1 then {enter}.

12. EXTENDED partition is number two so press 2 then {enter}.

13. Yet another drive check, more waiting :0)

14. Now we want to use the rest of the drive for the EXTENDED partition and by default it will show us this value. Press {enter}

15. Just a confirmation screen, we can see our nice new partitions now, press Esc.

16. Now because we’ve got an EXTENDED partition and no LOGICAL DRIVES, it gets us to create them by default, after another drive check of course :0)

17. Now by default it will try and use the whole EXTENDED partition, as we want two logical drives, we don’t want it to do this, so type in the size (In Megabytes) of the drive you want, in this case I’ve used 1024Mb (1Gb) then press {enter}.

18. And there she is! time for FDISK to do yet another drive check, just wait.

19. Now it wants us to use up the rest of the EXTENDED partition, if you want a LOT of LOGICAL DRIVES you can keep going, as we only want two just press {enter}.

20. OK there’s our two LOGICAL DRIVES and FDISK is telling us that we have used up all the EXTENDED partition, just press Esc.

21. Now the last thing we need to do is make the PRIMARY partition active (so you can boot from it) press 2 then {enter}.

22. There’s your PRIMARY partition at the top, so press 1 then {enter}.

23. Now FDISK tells us the partition is active, press Esc.

24. Back wherewe started :0) Press Esc.

25. Press Esc to exit FDISK, when you are back at command line press Ctrl+Alt+Del to reboot the PC. All your partitions are now created.

Once the PC has rebooted you can format each drive using the format c: command (substitute c for all your other drives. If you’re going to install windows 2000 or XP you won’t need to do this it can be done from the operating system setup.

Related Articles, References, Credits, or External Links

NA

Deleting Simple Partitions on your Hard Drive Using FDISK

KB ID 0000080

Problem

You want to remove the partitions form your carved up hard drive.

Solution

Deleting a Partition

1. First ensure you have a windows 98SE Bootdisk, you can download one, CLICK HERE

2. Boot the PC with your boot disk, ENSURE the boot order is set in the BIOS to boot from the floppy disk BEFORE the hard drive 3.To launch FDISK simply type fdisk {enter} at the command prompt, when the program launches press the Y key and {enter} to enable large drive support

4. This is the main FDISK menu, as we are Deleting a single partition we need to change the selection from the default [1] to [3] “Delete partition or logical DOS Drive”

5. Press 3 then {enter}

6. As there is only one partition leave the default setting of [1] and press {enter}

7. You will now see the partition displayed (In this case called partition 1) as this is the only partition it is selected by default, just press {enter}

8.You will now be asked to type in the “Volume Label” this drive is blank so you can just hit {enter} if yours has a label it will be shown in the volume label column (above)

9. You are asked to confirm (Last chance to change your mind :0)

10. Press Y then {enter} to confirm

11. This confirms the partition is deleted (You can now Exit FDISK if you do not want to create a partition, by pressing Esc) When you are back at command line press Ctrl+Alt+Esc to reboot the PC.

Related Articles, References, Credits, or External Links

NA

Simple Partitioning of your Hard Drive Using FDISK

KB ID 0000079

Problem

You want to carve up the space on your hard drive.

Solution

Creating a Partition

1. First ensure you have a windows 98SE Bootdisk, you can download one, CLICK HERE

2. Boot the PC with your boot disk, ENSURE the boot order is set in the BIOS to boot from the floppy disk BEFORE the hard drive

3.To launch FDISK simply type fdisk {enter} at the command prompt, when the program launches press the Y key and {enter} to enable large drive support

4. If its not allready selected change the choice to [1] Create DOS Partition or Logical DOS Drive. and {enter}

5. You now want to create a primary DOS partition press 1 then {enter}

6. FDISK will do a quick drive check.

7. You will be asked if you want to use the maximum space available, as we only want one partition accept the default of “Y” and press {enter}

8. FDISK will perform another drive check.

9. Hurrah! We’re done, Press Esc to exit FDISK then at command line press Ctrl+Alt+Delete to rebootand the partition is in place.

Related Articles, References, Credits, or External Links

NA

Hard Drive Partitioning

KB ID 0000078

Problem

This page deals with “Simple Partitioning” though reference will be made to how newer operating systems use partions.

Common Misconceptions

“All Partiions have a drive letter” NO

“All drive letters are a separate partition” NO

Solution

OK then! Take a hard drive, I will show it below as a “large block of space”

If you are only going to have one partition and its going to be your only drive letter then you would simply put in a PRIMARY PARTITION and set it to ACTIVE (So it can be booted from) once it has been formatted it will be the only drive (Usually C:)

However if you want the hard drive to appear as multiple drive letters c: d: etc then you need to partition it differently, you will still need your primary partition but it WONT fill up the entire drive space.

Now comes the confusing bit, if you want any more drives you need to create an EXTENDED partition. An extended partition will have NO drive letter assigned to it and cannot be formatted (Bear with me :0)

It is in the EXTENDED partition you can create further drives, create them one by one to fill up the extended partition – unless you want to leave some space for the future. Each of these drives are called LOGICAL DRIVES, and when formatted each will have its own drive letter.

This system is used by Operating systems like Windows 95/98/ME modern Operating systems like Windows 2000 and XP can utilise up to 4 Primary partitions, but lets keep things simple.

To set this up you would normally use the command line utility FDISK, Remember partitions MUST be created in this order Primary, Extended then Logical. And if your deleting partitions you MUST delete them in reverse order, Logical, Extended then Primary.

For a walkthrough on creating Primary partitions CLICK HERE

For a walkthrough on creating Primary/Extended Partitions, and Logical drives CLICK HERE

For a walkthrough on deleting Primary partitions CLICK HERE

For a walkthrough on deleting Primary/Extended Partitions, and Logical drives CLICK HERE

 

Related Articles, References, Credits, or External Links

NA