Webmin – Upgrade Error – ‘Perl (Net::SSLeay) is needed’


KB ID 0001100 Dtd 24/08/15


I like to keep my CentOS server updated as much as I can, but the last couple of times I've gone to run the upgrade of the Webmin console, I've got this;

webmin update error

error: Failed dependencies:

perl(Net::SSLeay) is needed by webmin (version)


1. As error messages go this is not a bad one, it obviously needs perl installing. So SSH into the server and execute the following command;

yum -y install perl perl-Net-SSLeay openssl perl-IO-Tty

webmin install perl

2. On successful completion, go back to Webmin and attempt the upgrade again.

webmin upgrade

Related Articles, References, Credits, or External Links


Author: Migrated

Share This Post On