ESX 4 to ESX 5 Upgrade Warning ‘Custom VIB Warning’


KB ID 0000500 Dtd 06/09/11


Seen when upgrading ESXi 4.1 U1 to ESX 5.

Custom VIB error

Error: <3RD_PARTY_SOFTWARE_WARNING: Host contains third-party VIB(s) that have no substitute on the ISO. [‘oem-vmware-esx-drivers-net-vxge’, ‘oem-vmware-esx-drivers-scsi-3w-9xxx’]>

If attempting to upgrade with VMware update manager you will see the following;

Custom VIB error


Luckily this was on a test box so I was somewhat more cavalier in my attitude than if I’d been on a clients production network, It goes without saying that you should not be proceeding with an upgrade without a good backup of your production VM’s anyway.

I simply chose the “Force Migrate” option, and the upgrade proceeded seamlessly. WARNING if your error message has different VIB’s listed, then see then DO NOT proceed without seeing the warning below.

Custom VIB error

What’s this all about?

VMware are wanting you to use the VMware PowerCLI utility to inject the custom VIB’s Into the ESX5 install media. At time of writing I could locate neither the VIB’s, or the depot install package I needed to do this.

Related Articles, References, Credits, or External Links


Author: Migrated

Share This Post On